Unexpected Inconsistensy after Grub reinstallation

Discussion in 'Linux' started by lifehacker, Sep 2, 2006.

  1. lifehacker

    lifehacker Member

    As expected, after installing Windows, the master boot record was overwritten. To load up my Fedora Core I therefore tried to reinstall Grub. Everything went until after the installation I tried to boot. Then I got the following message:
    Checking Filesystems : Failed
    /home : Unexpected Inconsistency, Run fsck manually.

    Anybody know what I should do now?
  2. lifehacker

    lifehacker Member

    Anyone?...
  3. cpugeniusmv

    cpugeniusmv Computer Genius Established Member

    Do you know which filesystem your /home partition uses?

    If it's ext3 or ext2 (and it probably is), then boot from a live cd (such as Knoppix) and run this command as root:

    Code:
    e2fsck -f /dev/hd??
    Where /dev/hd?? should be the device file that refers to your /home partition.

    Some examples:
    /dev/hda1 is the first primary partition on the master hard disk on the primary channel.
    /dev/hdd3 is the third primary partition on the slave hard disk on the secondary channel.

    If you don't know which one is your home partition, you may be able to mount the partitions from Knoppix (it automatically detects which partitions are linux filesystems and adds them to the filesystem table).
  4. Lord_of_the_Dense

    Lord_of_the_Dense Deicidic Chipmunk Revue Established Member

    I thought it said after Grab installation.

Share This Page